ログインしていません。

#1 2020-12-23 14:06:02

llnnn
メンバー
登録日: 2020-12-10
投稿: 2

icuのアップデートでlightdmが起動しない

icuが67.1.1から68.2.1にアップデートしたあとからlightdm等が起動しません
pacman -Uでダウングレードしてみたら起動しました
icuが他から依存されているので他のパッケージもダウングレードしなければいけないのですか?

オフライン

#2 2020-12-27 20:17:25

underodig
モデレータ
登録日: 2016-04-24
投稿: 118

Re: icuのアップデートでlightdmが起動しない

亀で済みません。

あくまで私見ですが、依存パッケージをダウングレードしなくても動作しているのであれば、そのままで良いと思います。
しばらくはpacman.confにてicu、lightdmのアップデートを禁止しておき、pacmanでのアップデートでicu、lightdmのアップデートが出たら、双方の最新版で正常に動作するかを
確認し、ダメだったらまた巻き戻し、アップデートを禁止。私はこんな感じです。

※目的のアプリ等がまったく動作しない場合は、目的のアプリが動作するまで依存関係にあるものを巻き戻す。(目的のアプリが動作してくれることが重要)
ただ、目的のアプリ動作のために、依存関係のLib等を巻き戻すことは希だと考えています

編集者 underodig (2020-12-27 20:21:40)

オフライン

クィック投稿

メッセージを書いて送信してください。
ボット判定

本当の人間が送信しようとしていることを確認します。

Board footer