ログインしていません。

#1 2019-10-26 18:45:52

underodig
モデレータ
登録日: 2016-04-24
投稿: 72

pacman5.1.3(5.2)とyayのアップデート問題について

いつもお世話になっております。

タイトルの通り、アップデートが出来ない状態でしたが、解決策が上がっていたのでざっくりと
転記しておきます。
https://bbs.archlinux.org/viewtopic.php?id=250197

問題
sudo pacman -Syuすると、依存関係を確認する段階で「pacman 5.2に更新するとyayの依存関係が
壊れる」的なことが表示され、すべての更新が中断されます。

解決策
yayをアンインストールすることで、pacmanが正常に動作するようになります。
yayについては対応済のものがgithubにあがっているので、それを利用します。

git clone https://aur.archlinux.org/yay-git.git
cd yay-git
makepkg
※makepkgの段階でgoが無いと言われる場合がありますので、その場合は
sudo pacman -S go
で追加してください。

sudo pacman -U yay-git-9.4.2.r2.g8d37981-1-x86_64.pkg.tar.xz

オフライン

クィック投稿

メッセージを書いて送信してください。
ボット判定

本当の人間が送信しようとしていることを確認します。

Board footer