ログインしていません。

#1 2019-05-28 21:48:27

coltrane
メンバー
登録日: 2019-05-28
投稿: 6

[解決済み] pcの再起動でbluetooth機器の接続が確立されません

bluetooth で困っています。
システム更新後、キーボードの接続は正常に確立されますが、PC再起動やbluetoothサービスを再起動すると
接続できなくなってしまいました。
bluez bluez-utils を再インストールしましたが改善されませんでした。
ArchWiki のBluetooth キーボードにある、
/etc/btkbd.conf 設定ファイルを作成し、
/etc/systemd/system/btkbd.service ファイルを作成しましたがだめでした。
かなり調べたのですが、有効な手段が見つかりませんでした。


/etc/bluetooth/main.confの[Policy]にも、以下の記述は追加しています。

AutoEnable=true

【動作環境】
カーネル:5.1.4-arch1-1-ARCH
bluez 5.50-6
キーボード:logicool K380
USBドングル使用

以下がキーボードの接続ログです。

[coltrane@coltrane ~]$ sudo bluetoothctl
Agent registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# scan on
Discovery started
[CHG] Controller 00:1B:DC:0F:72:24 Discovering: yes
[NEW] Device 34:88:5D:9C:9E:7B Keyboard K380
[bluetooth]# pair 34:88:5D:9C:9E:7B
Attempting to pair with 34:88:5D:9C:9E:7B
[CHG] Device 34:88:5D:9C:9E:7B Connected: yes
[agent] Passkey: 445798
[agent] Passkey: 445798
[agent] Passkey: 445798
[agent] Passkey: 445798
[agent] Passkey: 445798
[agent] Passkey: 445798
[agent] Passkey: 445798
[CHG] Device 34:88:5D:9C:9E:7B Modalias: usb:v046DpB342d4201
[CHG] Device 34:88:5D:9C:9E:7B UUIDs: 00001000-0000-1000-8000-00805f9b34fb
[CHG] Device 34:88:5D:9C:9E:7B UUIDs: 00001124-0000-1000-8000-00805f9b34fb
[CHG] Device 34:88:5D:9C:9E:7B UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device 34:88:5D:9C:9E:7B ServicesResolved: yes
[CHG] Device 34:88:5D:9C:9E:7B Paired: yes
Pairing successful
[CHG] Device 34:88:5D:9C:9E:7B ServicesResolved: no
[CHG] Device 34:88:5D:9C:9E:7B Connected: no
[bluetooth]# connect 34:88:5D:9C:9E:7B
Attempting to connect to 34:88:5D:9C:9E:7B
[CHG] Device 34:88:5D:9C:9E:7B Connected: yes
Connection successful
[CHG] Device 34:88:5D:9C:9E:7B ServicesResolved: yes
[Keyboard K380]# trust 34:88:5D:9C:9E:7B
[CHG] Device 34:88:5D:9C:9E:7B Trusted: yes
Changing 34:88:5D:9C:9E:7B trust succeeded
[Keyboard K380]# exit

その後、bluetoothサービスを再起動させると、以下のように失敗してしまいます。

[coltrane@coltrane ~]$ sudo bluetoothctl
Agent registered
[bluetooth]# 
[CHG] Device 34:88:5D:9C:9E:7B Connected: yes
[CHG] Device 34:88:5D:9C:9E:7B Connected: no
[bluetooth]# connect 34:88:5D:9C:9E:7B
Attempting to connect to 34:88:5D:9C:9E:7B
Failed to connect: org.bluez.Error.Failed
[bluetooth]# exit

解決策があればご教示をお願いします。

編集者 coltrane (2019-06-14 23:35:23)

オフライン

#2 2019-05-30 00:01:29

underodig
モデレータ
登録日: 2016-04-24
投稿: 71

Re: [解決済み] pcの再起動でbluetooth機器の接続が確立されません

2つ確認したいことがあります。

1)>システム更新後、キーボードの接続は正常に確立されますが、PC再起動やbluetoothサービスを再起
動すると接続できなくなってしまいました。

とありますが、更新後、bluetoothでのキーボード接続は一切出来ていないと考えてよいのでしょうか?
(もしくは、更新後PCの再起動やサービスの再起動したあとは繋がらなくても、手動で設定すると接続でき
るのでしょうか?)

2)レシーバーについて何もかかれていませんが、レシーバーはPCに内臓されていますか?それともUSB接続
等のレシーバーですか?

確認したい理由として
1)については、更新前に巻き戻した場合、正常に動作するなら更新された「何か?」に問題がある可能性が
あるので、設定等についてはとりあえず置いといて(むしろいじる前に戻して)、bugs.archlinux.org
などを調べて見るのが良いと思います。

2)については、レシーバーが内臓でない場合、別PCがあれば色々確認することが出来ます。
たとえば、ペアリングが正常に済んでいるレシーバーとキーボードの場合、別のPCにレシーバーを接続すれ
ば、特に何もしなくてもペアリング済みキーボードは使えると考えます。(PINコードやパスコードの入力
等は要求されない)
現在使っているレシーバーを別PCに接続してペアリングキーボードが正常に使える場合は、arch側の設定か
何かで問題がある可能性があり、逆に別PC(例えばWindowsの場合)で、PINコードやパスコードが要求され
た場合はレシーバーに暗号化キーが正常に記録されなかった(ペアリングが正常に出来なかった)可能性があ
るので、この場合はとりあえずWindows側で普通に使える状態になれば、archPCにレシーバーを接続して
も正常に動作する可能性があると思われます。

追記
USBドングルについて
私の頭の中では「ドングル=プロテクト」と考えているので、一度ドングルを外した状態ではどうなのか
確認されるのも良いかもしれません。

編集者 underodig (2019-05-30 00:06:01)

オフライン

#3 2019-05-30 06:12:48

coltrane
メンバー
登録日: 2019-05-28
投稿: 6

Re: [解決済み] pcの再起動でbluetooth機器の接続が確立されません

ご返事有難うございます。

1)システム更新後ですが、手動で接続できます。その後PC再起動やbluetoothサービス再起動で繋がらなくなります。

2)レシーバーは、USB接続のものを使用しています。lsusbの結果です。

Bus 003 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

まずは、すぐにできるところで、レシーバーを別のpcに接続して調べてみます。

結果は改めて報告致します。

編集者 coltrane (2019-06-03 17:27:50)

オフライン

#4 2019-05-30 23:19:35

coltrane
メンバー
登録日: 2019-05-28
投稿: 6

Re: [解決済み] pcの再起動でbluetooth機器の接続が確立されません

レシーバーをWindows10に装着してみました。
結果、問題なく接続が確立しました。再起動後も接続されたままでした。
おそらく、レシーバーは問題ないかと思います。

更新内容ですが、以下にpacmanのログを記載します。

[2019-05-25 03:53] [PACMAN] Running 'pacman -Syu'
[2019-05-25 03:53] [PACMAN] synchronizing package lists
[2019-05-25 03:53] [PACMAN] starting full system upgrade
[2019-05-25 03:54] [ALPM] transaction started
[2019-05-25 03:54] [ALPM] upgraded iana-etc (20190415-1 -> 20190504-1)
[2019-05-25 03:54] [ALPM] upgraded alsa-lib (1.1.8-1 -> 1.1.9-1)
[2019-05-25 03:54] [ALPM] upgraded alsa-plugins (1.1.8-1 -> 1.1.9-2)
[2019-05-25 03:54] [ALPM] upgraded bash (5.0.003-1 -> 5.0.007-1)
[2019-05-25 03:54] [ALPM] upgraded alsa-utils (1.1.8-1 -> 1.1.9-1)
[2019-05-25 03:54] [ALPM] upgraded file (5.36-1 -> 5.37-1)
[2019-05-25 03:54] [ALPM] upgraded systemd-libs (242.16-1 -> 242.29-1)
[2019-05-25 03:54] [ALPM] upgraded e2fsprogs (1.45.0-1 -> 1.45.1-1)
[2019-05-25 03:54] [ALPM] upgraded krb5 (1.16.1-1 -> 1.16.2-1)
[2019-05-25 03:54] [ALPM] upgraded dbus (1.12.12-1 -> 1.12.14-1)
[2019-05-25 03:54] [ALPM] upgraded glib2 (2.60.1-1 -> 2.60.3-1)
[2019-05-25 03:54] [ALPM] upgraded pcre2 (10.32-2 -> 10.33-1)
[2019-05-25 03:54] [ALPM] upgraded shadow (4.6-2 -> 4.6-3)
[2019-05-25 03:54] [ALPM] upgraded systemd (242.16-1 -> 242.29-1)
[2019-05-25 03:54] [ALPM] upgraded libwacom (0.32-1 -> 0.33-1)
[2019-05-25 03:54] [ALPM] upgraded libinput (1.13.1-1 -> 1.13.2-1)
[2019-05-25 03:54] [ALPM] upgraded nvidia-utils (418.56-1 -> 430.14-1)
[2019-05-25 03:54] [ALPM-SCRIPTLET] If you run into trouble with CUDA not being available, run nvidia-modprobe first.
[2019-05-25 03:54] [ALPM] upgraded libedit (20181209_3.1-1 -> 20190324_3.1-1)
[2019-05-25 03:54] [ALPM] upgraded mesa (19.0.3-1 -> 19.0.5-1)
[2019-05-25 03:54] [ALPM] upgraded tslib (1.19-1 -> 1.20-1)
[2019-05-25 03:54] [ALPM] upgraded avahi (0.7+18+g1b5f401-1 -> 0.7+18+g1b5f401-2)
[2019-05-25 03:54] [ALPM] upgraded android-file-transfer (3.7-2 -> 3.8-1)
[2019-05-25 03:54] [ALPM] upgraded attica (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded bash-completion (2.8-1 -> 2.9-1)
[2019-05-25 03:54] [ALPM] upgraded btrfs-progs (4.20.2-1 -> 5.1-1)
[2019-05-25 03:54] [ALPM] upgraded ca-certificates-mozilla (3.43-1 -> 3.44-1)
[2019-05-25 03:54] [ALPM] upgraded libuv (1.28.0-1 -> 1.29.1-1)
[2019-05-25 03:54] [ALPM] upgraded libssh2 (1.8.1-1 -> 1.8.2-1)
[2019-05-25 03:54] [ALPM] upgraded cmake (3.14.3-1 -> 3.14.4-1)
[2019-05-25 03:54] [ALPM] upgraded dhcpcd (7.0.8-1 -> 7.2.1-1)
[2019-05-25 03:54] [ALPM] upgraded ebook-tools (0.2.2-5 -> 0.2.2-6)
[2019-05-25 03:54] [ALPM] upgraded ethtool (1:5.0-1 -> 1:5.1-1)
[2019-05-25 03:54] [ALPM] upgraded exiv2 (0.26-2 -> 0.27.1-1)
[2019-05-25 03:54] [ALPM] upgraded v4l-utils (1.16.5-1 -> 1.16.6-1)
[2019-05-25 03:54] [ALPM] upgraded faudio (19.04-1 -> 19.05-1)
[2019-05-25 03:54] [ALPM] upgraded librsvg (2:2.44.13-1 -> 2:2.44.14-1)
[2019-05-25 03:54] [ALPM] upgraded fcitx (4.2.9.6-1 -> 4.2.9.6-2)
[2019-05-25 03:54] [ALPM] upgraded fcitx-gtk2 (4.2.9.6-1 -> 4.2.9.6-2)
[2019-05-25 03:54] [ALPM] installed js60 (60.7.0-1)
[2019-05-25 03:54] [ALPM] upgraded polkit (0.115+24+g5230646-1 -> 0.116-1)
[2019-05-25 03:54] [ALPM] upgraded glib-networking (2.60.1+2+g1ce6b40-1 -> 2.60.2-1)
[2019-05-25 03:54] [ALPM] upgraded libsoup (2.66.1-1 -> 2.66.2-1)
[2019-05-25 03:54] [ALPM] upgraded fcitx-gtk3 (4.2.9.6-1 -> 4.2.9.6-2)
[2019-05-25 03:54] [ALPM] upgraded nss (3.43-1 -> 3.44-1)
[2019-05-25 03:54] [ALPM] upgraded firefox (66.0.3-1 -> 67.0-1)
[2019-05-25 03:54] [ALPM] upgraded gd (2.2.5-1 -> 2.2.5-2)
[2019-05-25 03:54] [ALPM] upgraded gedit (3.32.0-2 -> 3.32.2-1)
[2019-05-25 03:54] [ALPM] upgraded geoclue (2.5.2-3 -> 2.5.3-1)
[2019-05-25 03:54] [ALPM] upgraded graphviz (2.40.1-14 -> 2.40.1-15)
[2019-05-25 03:54] [ALPM] upgraded gtksourceview3 (3.24.10-1 -> 3.24.11-1)
[2019-05-25 03:54] [ALPM] upgraded libraqm (0.5.0-1 -> 0.6.0-1)
[2019-05-25 03:54] [ALPM] upgraded imagemagick (7.0.8.42-1 -> 7.0.8.46-1)
[2019-05-25 03:54] [ALPM] upgraded intel-ucode (20190312-1 -> 20190514.a-1)
[2019-05-25 03:54] [ALPM] upgraded iproute2 (5.0.0-1 -> 5.1.0-1)
[2019-05-25 03:54] [ALPM] upgraded libbytesize (1.4-1 -> 2.0-1)
[2019-05-25 03:54] [ALPM] upgraded ndctl (64.1-2 -> 65-1)
[2019-05-25 03:54] [ALPM] upgraded parted (3.2-8 -> 3.2-9)
[2019-05-25 03:54] [ALPM] upgraded thin-provisioning-tools (0.8.0-1 -> 0.8.1-1)
[2019-05-25 03:54] [ALPM] upgraded solid (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kcoreaddons (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kwidgetsaddons (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kjobwidgets (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kdbusaddons (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kconfig (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kwindowsystem (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kcrash (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kglobalaccel (5.57.0-2 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kcompletion (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded qt5-declarative (5.12.3-1 -> 5.12.3-2)
[2019-05-25 03:54] [ALPM] upgraded ki18n (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kservice (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kauth (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kcodecs (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kguiaddons (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kconfigwidgets (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kitemviews (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded karchive (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kiconthemes (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded sonnet (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded ktextwidgets (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kxmlgui (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kbookmarks (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded libdbusmenu-qt5 (0.9.3+16.04.20160218-2 -> 0.9.3+16.04.20160218-4)
[2019-05-25 03:54] [ALPM] upgraded knotifications (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kwallet (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kio (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded libkcddb (19.04.0-1 -> 19.04.1-1)
[2019-05-25 03:54] [ALPM] upgraded kpackage (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kdeclarative (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kcmutils (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded knotifyconfig (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded poppler (0.76.0-1 -> 0.76.1-1)
[2019-05-25 03:54] [ALPM] upgraded poppler-qt5 (0.76.0-1 -> 0.76.1-1)
[2019-05-25 03:54] [ALPM] upgraded kfilemetadata (5.57.0-1 -> 5.58.0-3)
[2019-05-25 03:54] [ALPM] upgraded knewstuff (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded qt5-webkit (5.212.0alpha2-28 -> 5.212.0alpha2+156+g95401fe3908-1)
[2019-05-25 03:54] [ALPM] upgraded k3b (1:19.04.0-1 -> 1:19.04.1-1)
[2019-05-25 03:54] [ALPM] upgraded kpty (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kdesu (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kinit (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded kparts (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded konsole (19.04.0-1 -> 19.04.1-1)
[2019-05-25 03:54] [ALPM] upgraded kwayland (5.57.0-1 -> 5.58.0-1)
[2019-05-25 03:54] [ALPM] upgraded lib32-libcap (2.26-1 -> 2.27-1)
[2019-05-25 03:54] [ALPM] upgraded lib32-libgpg-error (1.35-1 -> 1.36-1)
[2019-05-25 03:54] [ALPM] upgraded lib32-systemd (242.16-1 -> 242.29-1)
[2019-05-25 03:54] [ALPM] upgraded lib32-dbus (1.12.12-1 -> 1.12.14-1)
[2019-05-25 03:54] [ALPM] upgraded lib32-e2fsprogs (1.45.0-1 -> 1.45.1-1)
[2019-05-25 03:54] [ALPM] upgraded lib32-mesa (19.0.3-1 -> 19.0.5-1)
[2019-05-25 03:55] [ALPM] upgraded lib32-nvidia-utils (418.56-1 -> 430.14-1)
[2019-05-25 03:55] [ALPM] upgraded lib32-faudio (19.04-1 -> 19.05-1)
[2019-05-25 03:55] [ALPM] upgraded lib32-glib2 (2.60.1-1 -> 2.60.3-1)
[2019-05-25 03:55] [ALPM] upgraded lib32-krb5 (1.16.1-1 -> 1.16.2-1)
[2019-05-25 03:55] [ALPM] upgraded lib32-lz4 (1.8.3-1 -> 1.9.1-1)
[2019-05-25 03:55] [ALPM] upgraded lib32-zstd (1.3.8-1 -> 1.4.0-1)
[2019-05-25 03:55] [ALPM] upgraded libgda (5.2.8+7+ga5355eb42-3 -> 5.2.9-1)
[2019-05-25 03:55] [ALPM] upgraded libgexiv2 (0.12.0-1 -> 0.12.0-2)
[2019-05-25 03:55] [ALPM] upgraded libimagequant (2.12.2-1 -> 2.12.3-1)
[2019-05-25 03:55] [ALPM] upgraded libreoffice-fresh (6.2.3-2 -> 6.2.4-1)
[2019-05-25 03:55] [ALPM] upgraded libreoffice-fresh-ja (6.2.3-1 -> 6.2.4-1)
[2019-05-25 03:55] [ALPM] upgraded libwbclient (4.10.2-1 -> 4.10.4-1)
[2019-05-25 03:55] [ALPM] upgraded libwnck3 (3.30.0-1 -> 3.32.0-2)
[2019-05-25 03:55] [ALPM] upgraded libxnvctrl (418.56-1 -> 430.14-1)
[2019-05-25 03:55] [ALPM] upgraded lightdm (1:1.28.0-3 -> 1:1.28.0-4)
[2019-05-25 03:55] [ALPM] upgraded linux-firmware (20190313.efd2c1c-1 -> 20190514.711d329-1)
[2019-05-25 03:55] [ALPM] upgraded mkinitcpio (25-1 -> 25-2)
[2019-05-25 03:55] [ALPM] upgraded linux (5.0.9.arch1-1 -> 5.1.4.arch1-1)
[2019-05-25 03:55] [ALPM] upgraded man-pages (5.00-1 -> 5.01-1)
[2019-05-25 03:55] [ALPM] upgraded metis (5.1.0.p5-1 -> 5.1.0.p6-1)
[2019-05-25 03:55] [ALPM] upgraded mlt (6.14.0-5 -> 6.16.0-1)
[2019-05-25 03:55] [ALPM] upgraded smbclient (4.10.2-1 -> 4.10.4-1)
[2019-05-25 03:55] [ALPM] upgraded mplayer (38125-5 -> 38139-1)
[2019-05-25 03:55] [ALPM] upgraded nvidia (418.56-9 -> 430.14-4)
[2019-05-25 03:55] [ALPM] upgraded nvidia-settings (418.56-1 -> 430.14-1)
[2019-05-25 03:55] [ALPM] upgraded perl-alien-build (1.69-1 -> 1.74-1)
[2019-05-25 03:55] [ALPM] upgraded perl-alien-libxml2 (0.07-1 -> 0.09-1)
[2019-05-25 03:55] [ALPM] upgraded perl-gd (2.69-1 -> 2.70-1)
[2019-05-25 03:55] [ALPM] upgraded perl-net-http (6.18-2 -> 6.19-1)
[2019-05-25 03:55] [ALPM] upgraded perl-libwww (6.38-1 -> 6.39-1)
[2019-05-25 03:55] [ALPM] upgraded perl-mailtools (2.20-2 -> 2.21-1)
[2019-05-25 03:55] [ALPM] upgraded poppler-glib (0.76.0-1 -> 0.76.1-1)
[2019-05-25 03:55] [ALPM] upgraded portaudio (190600_20161030-4 -> 1:19.6.0-5)
[2019-05-25 03:55] [ALPM] upgraded pyqt5-common (5.12.1-1 -> 5.12.2-1)
[2019-05-25 03:55] [ALPM] upgraded python-cairo (1.18.0-1 -> 1.18.1-1)
[2019-05-25 03:55] [ALPM] upgraded python-sip-pyqt5 (4.19.16-1 -> 4.19.17-1)
[2019-05-25 03:55] [ALPM] upgraded python-pyqt5 (5.12.1-1 -> 5.12.2-1)
[2019-05-25 03:55] [ALPM] upgraded python2-cairo (1.18.0-1 -> 1.18.1-1)
[2019-05-25 03:55] [ALPM] upgraded shotcut (19.02.28-1 -> 19.04.30-1)
[2019-05-25 03:55] [ALPM] upgraded smplayer (19.1.0-1 -> 19.5.0-1)
[2019-05-25 03:55] [ALPM] upgraded sqlitebrowser (3.11.1-1 -> 3.11.2-1)
[2019-05-25 03:55] [ALPM] upgraded systemd-sysvcompat (242.16-1 -> 242.29-1)
[2019-05-25 03:55] [ALPM] upgraded thunderbird (60.6.1-2 -> 60.7.0-1)
[2019-05-25 03:55] [ALPM] upgraded thunderbird-i18n-ja (60.6.1-1 -> 60.7.0-1)
[2019-05-25 03:55] [ALPM] upgraded tracker (2.2.1-2 -> 2.2.2-1)
[2019-05-25 03:55] [ALPM] upgraded vlc (3.0.6-11 -> 3.0.6-12)
[2019-05-25 03:55] [ALPM] upgraded vnstat (2.1-1 -> 2.2-1)
[2019-05-25 03:55] [ALPM] upgraded vte-common (0.56.2-1 -> 0.56.3-1)
[2019-05-25 03:55] [ALPM] upgraded vte3 (0.56.2-1 -> 0.56.3-1)
[2019-05-25 03:55] [ALPM] upgraded webkit2gtk (2.24.1-1 -> 2.24.2-1)
[2019-05-25 03:55] [ALPM] upgraded wine (4.7-1 -> 4.8-1)
[2019-05-25 03:55] [ALPM] upgraded xterm (344-1 -> 345-1)
[2019-05-25 03:55] [ALPM] transaction completed
[2019-05-25 03:55] [ALPM] running '60-linux.hook'...
[2019-05-25 03:55] [ALPM] running '90-linux.hook'...
[2019-05-25 03:55] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2019-05-25 03:55] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2019-05-25 03:55] [ALPM-SCRIPTLET] ==> Starting build: 5.1.4-arch1-1-ARCH
[2019-05-25 03:55] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2019-05-25 03:55] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2019-05-25 03:55] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2019-05-25 03:55] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2019-05-25 03:55] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2019-05-25 03:56] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2019-05-25 03:56] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2019-05-25 03:56] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2019-05-25 03:56] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-05-25 03:56] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2019-05-25 03:56] [ALPM-SCRIPTLET] ==> Image generation successful
[2019-05-25 03:56] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2019-05-25 03:56] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2019-05-25 03:56] [ALPM-SCRIPTLET] ==> Starting build: 5.1.4-arch1-1-ARCH
[2019-05-25 03:56] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2019-05-25 03:56] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2019-05-25 03:56] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2019-05-25 03:56] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2019-05-25 03:56] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2019-05-25 03:56] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2019-05-25 03:56] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2019-05-25 03:56] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2019-05-25 03:56] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2019-05-25 03:56] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-05-25 03:56] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2019-05-25 03:56] [ALPM-SCRIPTLET] ==> Image generation successful
[2019-05-25 03:56] [ALPM] running 'detect-old-perl-modules.hook'...
[2019-05-25 03:56] [ALPM] running 'gdk-pixbuf-query-loaders.hook'...
[2019-05-25 03:56] [ALPM] running 'gio-querymodules.hook'...
[2019-05-25 03:56] [ALPM] running 'glib-compile-schemas.hook'...
[2019-05-25 03:56] [ALPM] running 'gtk-query-immodules-2.0.hook'...
[2019-05-25 03:56] [ALPM] running 'gtk-query-immodules-3.0.hook'...
[2019-05-25 03:56] [ALPM] running 'gtk-update-icon-cache.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-binfmt.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-catalog.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-daemon-reload.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-hwdb.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-sysctl.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-sysusers.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-tmpfiles.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-udev-reload.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-update.hook'...
[2019-05-25 03:56] [ALPM] running 'texinfo-install.hook'...
[2019-05-25 03:56] [ALPM] running 'update-ca-trust.hook'...
[2019-05-25 03:56] [ALPM] running 'update-desktop-database.hook'...
[2019-05-25 03:56] [ALPM] running 'update-mime-database.hook'...
[2019-05-25 03:56] [ALPM] running 'update-vlc-plugin-cache.hook'...
[2019-05-25 03:56] [PACMAN] Running 'pacman --noconfirm --asdeps -S -- cups mariadb-libs postgresql-libs unixodbc'
[2019-05-25 03:56] [ALPM] transaction started
[2019-05-25 03:56] [ALPM] installed qpdf (8.4.2-1)
[2019-05-25 03:56] [ALPM] installed liblouis (3.9.0-1)
[2019-05-25 03:56] [ALPM] installed cups-filters (1.23.0-1)
[2019-05-25 03:56] [ALPM] installed bc (1.07.1-3)
[2019-05-25 03:56] [ALPM] installed cups (2.2.11-2)
[2019-05-25 03:56] [ALPM-SCRIPTLET] >> If you use an HTTPS connection to CUPS, the first time you access
[2019-05-25 03:56] [ALPM-SCRIPTLET] >> the interface it may take a very long time before the site comes up.
[2019-05-25 03:56] [ALPM-SCRIPTLET] >> This is because the first request triggers the generation of the CUPS
[2019-05-25 03:56] [ALPM-SCRIPTLET] >> SSL certificates which can be a very time-consuming job.
[2019-05-25 03:56] [ALPM] installed mariadb-libs (10.3.15-1)
[2019-05-25 03:56] [ALPM] installed postgresql-libs (11.3-1)
[2019-05-25 03:56] [ALPM] installed unixodbc (2.3.7-2)
[2019-05-25 03:56] [ALPM] transaction completed
[2019-05-25 03:56] [ALPM] running 'gtk-update-icon-cache.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-daemon-reload.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-sysusers.hook'...
[2019-05-25 03:56] [ALPM] running 'systemd-update.hook'...
[2019-05-25 03:56] [ALPM] running 'texinfo-install.hook'...
[2019-05-25 03:56] [ALPM] running 'update-desktop-database.hook'...
[2019-05-25 04:07] [PACMAN] Running 'pacman -U android-studio-3.4.1.0-1-x86_64.pkg.tar.xz'
[2019-05-25 04:07] [ALPM] transaction started
[2019-05-25 04:08] [ALPM] upgraded android-studio (3.4.0.18-2 -> 3.4.1.0-1)
[2019-05-25 04:08] [ALPM] transaction completed
[2019-05-25 04:08] [ALPM] running 'systemd-update.hook'...
[2019-05-25 04:08] [ALPM] running 'update-desktop-database.hook'...
[2019-05-25 04:09] [PACMAN] Running 'pacman -U dropbox-73.4.118-1-x86_64.pkg.tar.xz'
[2019-05-25 04:09] [ALPM] transaction started
[2019-05-25 04:09] [ALPM] upgraded dropbox (71.4.108-1 -> 73.4.118-1)
[2019-05-25 04:09] [ALPM] transaction completed
[2019-05-25 04:09] [ALPM] running 'systemd-daemon-reload.hook'...
[2019-05-25 04:09] [ALPM] running 'systemd-update.hook'...
[2019-05-25 04:09] [ALPM] running 'update-desktop-database.hook'...
[2019-05-25 04:11] [PACMAN] Running 'pacman -U google-chrome-74.0.3729.169-1-x86_64.pkg.tar.xz'
[2019-05-25 04:11] [ALPM] transaction started
[2019-05-25 04:11] [ALPM] upgraded google-chrome (74.0.3729.108-1 -> 74.0.3729.169-1)
[2019-05-25 04:11] [ALPM-SCRIPTLET] (B[m[1m[34m==>(B[m[1m[33m NOTE:(B[m[1m Custom flags should be put directly in: ~/.config/chrome-flags.conf(B[m
[2019-05-25 04:11] [ALPM-SCRIPTLET] (B[m[1m[34m==>(B[m[1m[33m NOTE:(B[m[1m The launcher is called: 'google-chrome-stable'(B[m
[2019-05-25 04:11] [ALPM] transaction completed
[2019-05-25 04:11] [ALPM] running 'gtk-update-icon-cache.hook'...
[2019-05-25 04:11] [ALPM] running 'systemd-update.hook'...
[2019-05-25 04:11] [ALPM] running 'update-desktop-database.hook'...

編集者 coltrane (2019-06-03 17:15:16)

オフライン

#5 2019-05-31 22:56:29

underodig
モデレータ
登録日: 2016-04-24
投稿: 71

Re: [解決済み] pcの再起動でbluetooth機器の接続が確立されません

www.archlinux.orgのフォーラムにて以下の書き込みを見つけました

https://bbs.archlinux.org/viewtopic.php?id=246540
症状がよく似ているので一度ご確認ください。
でquan2mさんの書き込みを以下転記。
Something whacky is going on with post 5.1+ kernels and bluetooth keyboards. I just downgraded for the first time in at 7yrs to fix the bluetooth keyboard problem. 5.0.13 seems to be last kernel that behaves in a sane fashion.

The downgrade tool works very well. Thus far everything seems to be working fine with downgrading just linux and linux-headers

https://wiki.archlinux.org/index.php/do … g_packages

同じ問題だった場合、カーネルを巻き戻すことで、問題が解決するそうなので、linuxカーネルと
linux-headersを巻き戻す(ダウングレード)ことで解決するかもしれません。

オフライン

#6 2019-06-04 08:44:57

coltrane
メンバー
登録日: 2019-05-28
投稿: 6

Re: [解決済み] pcの再起動でbluetooth機器の接続が確立されません

有用な情報ありがとございます。
早速試してみましたが、自分の環境でカーネルをダウングレードすると、グラフィックドライバーが認識されず画面が真っ暗になってしまいました。
休日にでもじっくり原因を調べて試してみたいと思います。
またその結果を報告させていただきます。

オフライン

#7 2019-06-06 20:36:18

underodig
モデレータ
登録日: 2016-04-24
投稿: 71

Re: [解決済み] pcの再起動でbluetooth機器の接続が確立されません

誠に申し訳ございません。
カーネル関係をダウングレードする場合は、ドライバ等もダウングレードしたほうが良いのですが、記述し
ておりませんでした。
今回の場合、nvidia関係のものをダウングレードすることになるのですが、依存関係等を考えるとどこま
で依存関係にあるパッケージのダウングレードしなければならないのかが見当も付きません。

また、
bugsに2019/05/29付けで報告が上がっていました。(おそらくこれではないかとおもいます)
https://bugs.archlinux.org/task/62776?p … &sort=desc

カーネルのダウングレードでの解決方法以外に、Fedora RFC patchを使って問題を解決する方法が記述
されています。(Fedoraでは既に同バージョンカーネルの修正が入っているそうです)

問題は周知されている様なので、近いうちに修正がはいるかもしれません。
※ちなみに昨日付けでlinux-5.1.7.arch1-1-x86_64が来ています。

オフライン

#8 2019-06-10 10:32:35

coltrane
メンバー
登録日: 2019-05-28
投稿: 6

Re: [解決済み] pcの再起動でbluetooth機器の接続が確立されません

本件とは異なる内容にもかかわらず、カーネルダウングレードについてのアドバイスありがとうございます。
nvidea関連をダウングレードしてみましたが、やはり真っ暗な状態となりできませんでした。
初期インストールから2年以上経過していたこともあり、これを機にリカバリー致しました。
カーネルは5.1.7.arch1-1です。
その結果、buletoothについて少し状況が改善された気がします。
今までは再起動後100%接続できませんでしたが、何度かに1度は接続されます。
おそらく何らかの改善策が講じられたのではないかと思いますが、次回のカーネルアップで
もう少し様子を見てみます。
あと、Fedora RFC patchについては、自分なりに調べて試したいと思います。

オフライン

#9 2019-06-10 20:55:08

underodig
モデレータ
登録日: 2016-04-24
投稿: 71

Re: [解決済み] pcの再起動でbluetooth機器の接続が確立されません

状況承知致しました。
あまりお役に立てませんでしたが、また何かございましたらご利用ください。

オフライン

#10 2019-06-14 23:28:37

coltrane
メンバー
登録日: 2019-05-28
投稿: 6

Re: [解決済み] pcの再起動でbluetooth機器の接続が確立されません

報告です。
本日、5.1.9-arch1-1 にアップしたところ、改善されました。

オフライン

クィック投稿

メッセージを書いて送信してください。
ボット判定

本当の人間が送信しようとしていることを確認します。

Board footer