ログインしていません。

#1 2018-06-03 00:16:08

underodig
メンバー
登録日: 2016-04-24
投稿: 35

yaourtでpackage-queryエラーについて

※管理人殿
何も考えずシステム管理に投稿してしまいました。適切なジャンルへの移動をお願いいたします。

いつもお世話になっております。
yaourtでのpackage-queryエラーについて転記しておきます。
ここ最近のアップデート以降yaourtが正常に動作しなくなり、以下のエラーが出るようになりました。
※すで家のPCでは問題解決してしまっているため、エラーを張ることができなかったので、以下のエラーも転記になります。

$ yaourt -Syua
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory
[sudo] password for judd:
:: Sincronizando las bases de datos de los paquetes...
core está actualizado
extra está actualizado
community está actualizado
multilib está actualizado
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory

解決方法は2つあり、一つはシンボリックリンクを張って解決する方法、もう一つはpackage-queryを再構築する方法です。
前者は、海外本スレにて問題があるとの指摘が多数記述されていたので、後者にての解決法のみ転記しておきます。
※gitをインストールしていない場合は、sudo pacman -S gitにてインストールしてから以下のコマンドを実行してください。

$ git clone https://aur.archlinux.org/package-query.git
$ cd package-query
$ makepkg
$ sudo pacman -U package-query-1.9-3-x86_64.pkg.tar.xz

編集者 underodig (2018-06-03 00:34:40)

オフライン

クィック投稿

メッセージを書いて送信してください。
ボット判定

本当の人間が送信しようとしていることを確認します。

Board footer